Repository navigation
Conversation
Fixes GHSA-2464-fhr4-w9xw and GHSA-673q-mjm6-r5xr (remote code execution in next 16.0.0 - 16.4.0), patched in 16.4.1: GHSA-2464-fhr4-w9xw Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com> Claude-Session: https://claude.ai/code/session_01FPBJ9DRFq4u6eoLci23B6S
In-range updates for webpack-dev-server deps of the example apps. proxy-addr 2.0.7 -> 2.0.8: GHSA-jqcg-44mw-7w3h shell-quote 1.10.0 -> 1.12.0: GHSA-pqg4-j6r4-53mv Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com> Claude-Session: https://claude.ai/code/session_01FPBJ9DRFq4u6eoLci23B6S
preact-cli is unmaintained and its parents pin vulnerable ranges of loader-utils, form-data and tar, so force the patched versions. GHSA-76p3-8jx3-jpfq GHSA-fjxv-7rqg-78g4 GHSA-23hp-3jrh-7fpw Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com> Claude-Session: https://claude.ai/code/session_01FPBJ9DRFq4u6eoLci23B6S
Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com> Claude-Session: https://claude.ai/code/session_01FPBJ9DRFq4u6eoLci23B6S
Contributor
pnpm exec changesetto create a changeset. |
Contributor
Coverage report
Test suite run success41 tests passing in 15 suites. Report generated by 🧪jest coverage report action from 7c295cf Show full coverage report
|
Contributor
There was a problem hiding this comment.
🔵 Needs a closer look
Cross-major dependency overrides in legacy Preact tooling need human compatibility confirmation beyond the reported example builds.
No open issues 🎉
What changed in this PR
Adds recurring dependency security checks and updates vulnerable dependencies in the examples without changing the published SDK.
Changes:
- Runs a production-dependency audit for critical advisories on every PR, daily, and manually.
- Upgrades both Next.js examples to version 16.4.2.
- Adds transitive dependency overrides for legacy Preact build tooling.
| File | Description |
|---|---|
pnpm-workspace.yaml |
Overrides vulnerable versions of loader-utils, form-data, and tar. |
examples/next/package.json |
Upgrades Next.js to 16.4.2. |
examples/next-appDir/package.json |
Upgrades Next.js to 16.4.2. |
.github/workflows/audit.yml |
Adds PR, daily, and manual dependency audits. |
Review effort: Balanced
This branch has not been deployed
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Part of INTER-2697.
Why
Catch critical advisories in dependencies on every PR and daily, since new advisories appear without code changes.
Things to note
pnpm audit --prod --audit-level critical.--prodskips devDependencies but still covers thedependenciesof every workspace project: the SDK's runtime deps (@fingerprint/agent) and the examples' frameworks (next,react-scripts, ...). On main it fails on 7 criticals, all in examples.nextcommit is the same change as INTER-2697: chore: bump next to 16.4.2 in Next.js examples #214 (cherry-picked, identical lockfile). It drops out on rebase once INTER-2697: chore: bump next to 16.4.2 in Next.js examples #214 merges.overridesinpnpm-workspace.yaml. The React 19 e2e jobs replaceoverrideswithpnpm config set, so they install the old versions. That is harmless there: those jobs reinstall without a frozen lockfile and never ship anything.Verification
pnpm auditrun on a copy of the lockfile and manifests, with nonode_modules:--prod --audit-level critical--audit-level critical(full)Locally: lint,
tsc --noEmit,test:coverage(41 passed),build,test:dtsand all 6 example builds pass.pnpm peers checkshows one new warning,webpack-cli@7.2.1wantswebpack-dev-server ^5 || ^6but gets 4.15.2. It comes from thenextbump re-resolving peers and is in #214 too.Change outline
New workflow
.github/workflows/audit.yml: runs onpull_request, daily cron, and manually. Setup matchese2e.yml.Dependency fixes, one per advisory:
The overridden packages are only in the preact example's dev tooling. html-webpack-plugin 3 only calls
parseQueryandstringifyRequest, which loader-utils 1.x keeps. Only gittar (preact create) callstar.extract, which tar 7 keeps. The preact example still builds.No changeset: nothing in the published package changes.
Generated by Claude Code