From ae44de2628393068de419b4e230a800150b5e38b Mon Sep 17 00:00:00 2001 From: "renovate[bot]" <29139614+renovate[bot]@users.noreply.github.com> Date: Sun, 1 Nov 2026 09:59:37 +0000 Subject: [PATCH] chore(deps): update overrides tar@7 to >=7.5.22 [security] --- package.json | 2 +- pnpm-lock.yaml | 10 +++++----- 2 files changed, 6 insertions(+), 6 deletions(-) diff --git a/package.json b/package.json index 6d7c61fe..917235f2 100644 --- a/package.json +++ b/package.json @@ -93,7 +93,7 @@ "glob@11": ">=11.1.0", "minimatch@10": ">=10.2.3", "postcss@8": ">=8.5.10", - "tar@7": ">=7.5.16", + "tar@7": ">=7.5.22", "rollup@4": ">=4.59.0", "svgo@3": ">=3.3.3", "launch-editor@2": ">=2.14.1", diff --git a/pnpm-lock.yaml b/pnpm-lock.yaml index 8e8ee1e7..4947264f 100644 --- a/pnpm-lock.yaml +++ b/pnpm-lock.yaml @@ -23,7 +23,7 @@ overrides: glob@11: '>=11.1.0' minimatch@10: '>=10.2.3' postcss@8: '>=8.5.10' - tar@7: '>=7.5.16' + tar@7: '>=7.5.22' rollup@4: '>=4.59.0' svgo@3: '>=3.3.3' launch-editor@2: '>=2.14.1' @@ -7216,8 +7216,8 @@ packages: engines: {node: '>=10'} deprecated: Old versions of tar are not supported, and contain widely publicized security vulnerabilities, which have been fixed in the current version. Please update. Support for old versions may be purchased (at exorbitant rates) by contacting i@izs.me - tar@7.5.20: - resolution: {integrity: sha512-9FcyK4PA6+WbzlTM9WhQm6vB5W7cP7dUiPsv1g7YDwEQnQ1CGpK3MGlKk/ITVWMk05kHZuBhmVhiv8LZoy/PFQ==} + tar@7.5.22: + resolution: {integrity: sha512-MFO/QzvtAOmJbkhOaCTvbGcFN9L9b+JunIsDwaKljSOdcLMea3NJ1k9Usz/rjdfSXTq4dfzfeS7W4p4YOAAHeA==} engines: {node: '>=18'} temp-dir@3.0.0: @@ -9292,7 +9292,7 @@ snapshots: node-fetch: 2.6.7(encoding@0.1.13) nopt: 8.1.0 semver: 7.8.5 - tar: 7.5.20 + tar: 7.5.22 transitivePeerDependencies: - encoding - supports-color @@ -15851,7 +15851,7 @@ snapshots: mkdirp: 1.0.4 yallist: 4.0.0 - tar@7.5.20: + tar@7.5.22: dependencies: '@isaacs/fs-minipass': 4.0.1 chownr: 3.0.0